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Introduction 
Welcome to Taxprep for Trusts 2026! 

This Quick Start Guide is designed to acquaint you with the Taxprep for Trusts program as 
well as to give you tips on how to use the program. This is not an in-depth guide; please refer 
to the Help any time for tax or technical assistance when you are in the program. For 
information on tax changes, please refer to the Release Notes for each version.
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Overview 

Different Views 
The Taxprep for Trusts program is comprised of several different views that allow you to 
perform different functions within the program. 

The Taxprep for Trusts Views 

 
The Professional Centre provides important information about the program, tax 
news and links for customer service and support. 

 

The Client Manager displays all of your tax returns. You can use it to open and 
roll forward files, print returns, EFILE slips, create reports and perform other 
functions that help you to manage the tax preparation process. 

 
The Tax Return view is where you prepare the return. You can print or transmit 
any open tax return from here. 

 

The Print Formats view is where you define the print settings for each form 
included in the tax return, such as the number of copies and the printer 
selection.  

 
The Preparer Profiles view allows you to create and manage one or more 
preparer profiles. 

 

The Filters and Diagnostics view contains predefined and customized filters and 
diagnostics that you apply in the Client Manager or in the diagnostics pane to 
generate reports or identify certain situations.  

 
The Letters and Labels view is where you create customized templates for 
letters, invoices and labels. 

 
The Rate Tables is where you establish the values and rates used in the current 
year tax return. 

 
The EFILE Log lists all the transactions related to electronically filed returns and 
provides follow-up options and reports. 

 
The EFILE Archive stores archived transactions from the EFILE Log. 
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Accessing Views 
The various views in the program are accessed using the Menu button.  

 
 

 

 

You can also access the views using the 
applicable shortcut key combinations. 

The name of the current view appears beside the Menu button.  

 

Toolbar 
The toolbar provides quick access to the most common commands in the program.  

 
The icons displayed on the toolbar will vary. For example, different icons will be displayed 
when you are viewing the Form Manager vs. when you are viewing a form.  

The toolbar icons will also vary from view to view, as some commands may not be applicable 
in all views.  
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The Professional Centre 
The Professional Centre is a dedicated Web page that provides the latest information on the 
program, including automatically alerting you to any program updates.  

On the Professional Centre, you will see a link to the Help Centre and to support documents 
such as the Release Notes as well as links to training resources and to the searchable 
Knowledge Base. The Professional Centre also provides a link to submit a support ticket to 
the Customer Service and Support teams. 

For more information on the Taxprep Help Centre and the Knowledge Base, see page 32.  

Default View 
By default, when you launch Taxprep for Trusts, the Tax Return view will be displayed. 
However, in Tools/Options and Settings (see below), you can configure the program to 
automatically open in the Client Manager or EFILE Log. 

Setup 

Options and Settings 
You can configure most aspects of the program using the Options and Settings command on 
the Tools menu. 

Note: If you are using the Network version, several options and settings may be pre-configured 
for various user groups. Check with your Network Administrator for more information. 
Click the section title to see a description of the options and settings contained in each 
section. Any changes that you make will be saved automatically when you click OK or Apply. 

Note: The options and settings are saved on your workstation and are unique to you. 

Preparer Profile 
Your preparer profile is configured in the Preparer Profiles view. You can have multiple 
Preparer Profiles.  

Click New to create a preparer profile. If you do not create a preparer profile, the program 
will use the defaults for the various options presented in the Preparer Profile view and the 
name of your firm will remain blank on page 4 of the T3 jacket. 

The Preparer Profile edit screen has seven tabs: Profile, Staff, Authorization Forms, EFILE, 
Client Letter, Bill and Interest. 
Click the Profile tab to enter information about your firm and your preferences with respect 
to preparing and filing your returns. 
Click the Staff tab to enter the names of the staff and partners using Taxprep for Trusts for 
purposes of selecting these names in each return for tracking purposes.  

Click the Authorization Forms tab to enter information and modify settings used when 
completing and filing the authorization forms. 

Click the EFILE tab to modify the settings used for the electronic filing of the T3 returns, Form 
T1135 and the T3, NR 4 and RL 16 information slips. 
Click the Client Letter tab to configure the options for the client letter, including entering any 
standard opening or closing paragraphs. 
Click the Bill tab to configure your billing options in the Invoice Profile, including the 
standard charges for the detailed invoice. 

 TIP
When creating 
additional preparer 
profiles, you can 
make a copy of any 
existing profile and 
simply change 
selected fields. 
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Click the Interest tab to configure the default settings for the Form Interest (Jump Code: 
Interest), which can be used to calculate interest on unpaid balances and late-filing 
penalties. 
The first time you save a preparer profile, the program will display the Preparer Profile 
Properties dialog box. 
You can enter a new name and description for your preparer profile. Click Default if you want 
that preparer profile to be used by default. You can change the information in this dialog box 
at any time using the Set Properties command. Click OK to return to the Preparer Profile 
view. 
All of the profiles that you create will appear in the list of Preparer Profiles. A check mark will 
appear beside the default Preparer Profile. 
Refer to the Help for more information on the Preparer Profile. 

Preparing Returns 

Roll Forward 
If your firm used Taxprep for Trusts last year, the files for any trust returns prepared last year 
that must also be completed in the current year can be rolled forward from the prior year. 

What is a Roll Forward? 
The roll forward procedure creates a new file for the current taxation year based on what was 
in last year’s return to avoid re-entering information that was gathered in a prior year. 

When a file is rolled forward, the permanent information (e.g. name of trust, address of 
trustee, account number) is retained and the closing balances of carryforward amounts (e.g. 
unutilized prior-year losses and minimum tax carryover) become the opening balances. 
Beneficiary information entered in Form BENEF and beneficial ownership information entered 
in Schedule 15 will also be retained unless otherwise indicated.  

In addition, the data entered in the prior year file is retained for comparison purposes.  

Using the Roll Forward 
From the Tax Return view, you can roll forward one or more client files from a single folder as 
follows: 

• On the File menu, click Roll Forward. 
• Select the folder where the client files to roll forward are located. 

• Select the client file(s) from last year that you want to roll forward.  

• Click Open. 

• The Roll Forward dialog box will be displayed on the screen. In the File Options and Data 
Options tabs, select the desired options.  

• Click OK to start the roll forward process. 

When a single file is rolled forward, it opens in the Identification form. 

You can also roll forward files created in the current version of Taxprep for Trusts: for 
instance if the trust is winding up in 2026.  
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Rolling forward files from Multiple Folders 
If your prior year files are in different folders, you can use the Client Manager to view a list of 
all of last year’s files from multiple locations and select the files that you want to roll 
forward.  

Converting files from other programs 
You can convert and roll forward files from other programs in the same manner as you roll 
forward Taxprep for Trusts files.  

If you are rolling forward these from the Tax Return view, select the appropriate file type 
from the drop-down list in the bottom right corner of the Roll Forward dialog box. 

   
If you are converting files from other programs using the Client Manager, select the 
appropriate file type from the list beside the “Files to Roll Forward” filter. 

Opening Files 
To open an existing file, or a file that has been rolled forward, select Open on the File menu. 

In Taxprep, you can have multiple files open at the same time.  

You can open several client files at the same time using the Client Manager. Simply select the 
client files you want to open, then on the File menu, click Open. 

Opening Prior Year Files Using Shortcuts 
When rolling forward the prior year client file, a shortcut to that client file will be 
automatically created. The shortcut will allow you to quickly access the prior year file. 

This shortcut will be available using the Prior Year/Open last year's client file command on 
the File menu or by pressing Ctrl+E. It is also accessible by clicking the Prior Year icon on the 
toolbar and selecting a shortcut to a prior year file. 

When you click the shortcut for the 2025 client file, it will be opened in the 2026 version of 
Taxprep for Trusts, provided it is installed and accessible. If you have rolled forward a 2024 
file to 2025 (e.g., for the first year of a GRE), clicking the shortcut to the 2025 file will open the 
file in the current version.  

You can also modify or delete existing shortcuts and create new shortcuts manually. 

Note that you can manually add shortcuts to other current year client-files (e.g. shortcuts to 
client files for related trusts). Once created, the shortcut will allow you to quickly access 
another client file. 

Client Manager 
The Client Manager provides information on all of your client files. 

It is used when you want to perform a function on multiple returns, such as: 

• opening returns; 

• rolling forward data; 

• recalculating returns; 

 TIP 
Once you have 
finished work on a 
specific data file, 
close the file to 
avoid entering data 
into the wrong 
return.

javascript:kadovTextPopup(this)
javascript:kadovTextPopup(this)
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• changing the return status 

• locking the data 

• applying passwords; 

• importing data; 

• generating reports on your clients; 

• printing returns; 

• printing letters and labels; 

• electronic filing; 
• syncing contact information with CCH iFirm. 

The Client Manager is also a useful tool for easily locating the files that you want to open. 
You can sort your returns by any field and find a return simply by typing the trust name. 

For more information on the Client Manager, refer to the Help. 

Starting a New Return 
Click New to start a new return. 

Taxprep for Trusts will open in the Identification form. 

If you are using CCH® iFirm®, you can sync certain identification data between the Taxprep for 
Trusts client file and your client contacts in CCH iFirm. Refer to the Help for more information. 

Accessing Forms 
There are several different methods for accessing forms in Taxprep for Trusts: selecting forms 
from the Form Manager, using the Form Assistant – Taxprep for Trusts (Jump Code: ASSIST) or 
using Xpress. 

Form Manager 
To access the Form Manager, press F4 or click the Form Manager icon on the toolbar. 

The Form Manager provides easy access to the various forms available in Taxprep. 

Simply select the form that you want then press Enter or double-click to open the form. 

To help you locate your forms quickly, Taxprep assigns a jump code for each form. Simply 
start typing the jump code and Taxprep will search for that code. 

Jump Code conventions: 

• Jacket: J for Federal T3 / Q for Québec TP646 

• Schedules: Schedule number (e.g. 9 for Schedule 9) 

• Slips: T-slips number (e.g. T5) 

• Worksheets: Acronym or short form (e.g. OID for Other income and deductions) 

Note: Jump codes used for the Québec return are preceded by the letter “Q” (e.g. QA for 
Schedule A).  

If you don’t know the jump code of a form, you can use the “Search” field on the toolbar (or 
press Ctrl+F). Simply enter your search text and the program will display all of the forms that 
contain that search text as part of the jump code, title or description.  

 TIP
In tables like the 
Client Manager and 
Form Manager, you 
can select items in 
several ways: 

• To select 
adjacent items, 
click the first 
item, and then 
press Shift while 
clicking the last 
item. 

• To select non-
adjacent items, 
click the first 
item, and then 
press Ctrl while 
clicking each 
item. 

• To select the 
entire list, click 
on the first item, 
and then press 
Shift and End 
simultaneously. 
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Open Forms 
Once a form is open, a tab for the form will appear at the top of the form display. Click any 
form tabs to view an open form. Click the Close (X) button or press the Esc key to close the 
form and remove the form tab. 

You can also access forms by drilling down from a form using the Forms/Expand command 
(e.g. beginning in the Jacket and expanding). 

Press F6 to toggle back and forth between the current form and the last form viewed. 

Press F8 to toggle between federal and provincial equivalent forms. 

Press F4 to toggle between the Form Manager and the open forms. 

Note: The program will retain information about what forms were opened and where the 
cursor was positioned, so that the next time the file is opened (by any user), the same forms 
will be opened automatically.  

ASSIST Form 
The Assistant – Taxprep for Trusts form (Jump Code: ASSIST), is designed to help you locate 
the forms that you need to complete for your trust return. 

Just follow the instructions provided on the screen to enter the information required to 
complete the tax return. As you follow each step on the form, you have direct access to the 
applicable data entry screens. 

Xpress 
Taxprep Xpress allows you to view the data in the return in a table format. You can select a 
filter to limit the data that you are viewing (e.g. only view the data entered in the current 
year). 

The data in the Xpress table is fully interactive with the data in the forms. Any change made 
on the form will be immediately reflected in the Xpress table and vice versa. 

Instead of jumping from form to form to enter data, with Xpress, you can simply scroll 
through the list of data entered in prior years and type in this year’s amounts. 

On the View menu, click Xpress (or click the Xpress icon on the toolbar) to display Xpress. 

You have two options for displaying Xpress: Dock and Float. 

If you choose Dock, Xpress will be displayed in a pane at the bottom of the Taxprep window. 
If you choose Float, Xpress will be displayed in a separate window which you can reposition 
(e.g. onto a second monitor). 

Xpress can also be a useful tool for reviewing the return. See page 18 for more information. 

Expand (F9) 
When you are on a form, you can move to another related form by “Expanding.” 

Expanding allows you to move from one form to another without first going to the Forms 
Manager. You can expand from any cell with an arrow symbol beside it  to 
display that cell’s source form. 

Access a source form from an expandable cell as follows: 

• on the Forms menu, click Expand. 

• right-click and then click Expand on the shortcut menu. 

• press F9. 

 TIP 
As most returns use 
more or less the 
same forms and 
fields from one year 
to another, using 
Xpress is an 
excellent way of 
quickly accessing 
the fields that you 
are most likely to 
need to complete 
for the current year. 
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• double-click the cell, or 

Cell Display 
Taxprep for Trusts uses flags to identify the properties of the cells. The colours indicate if the 
cell is calculated, calculated but overrideable, or input. The following are descriptions of the 
most common cell display: 

Cell Type Appearance Definition 

Input cell 
 

Black text on white 
background  

Data entry cell. 

Protected cell 
 

Black text on same colour 
background as the form 

No input or override is possible. 

Overrideable cell 
 

Black text on grey 
background 

Calculated cell where content can be 
overridden. 

Posted cell 
 

Blue arrow pointing into the 
cell. 

Cell in which the content comes from 
another form. 

Overridden cell 
 

Black text on pink 
background  

Calculated or posted cell where 
content has been overridden. 

Rolled Forward 
cell 

 
Blue text on white 
background 

Cell that was rolled forward from the 
prior year 

Cells with data 
entered last year 
but not this year 

 
Black text on yellow 
background 

Cell in which data was entered last 
year but no value has been entered 
or rolled forward in the current year 

Cells with review 
marks 

 
Red indicator on the right 
side of the cell 

Cell that has been marked as part of 
a review. Five types of review marks 
are available. 

Cell with 
diagnostic 

   
Red triangle in the upper 
right corner  

Cell for which a diagnostic has been 
issued. 

Annotated cell 
 

Paper clip in the upper left 
corner 

Cell to which a note or schedule has 
been attached. 
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Cell Type Appearance Definition 

Cell with tax link 
 

Blue triangle in the lower 
right corner  

Cell with an InfoConnect Tax Hint and 
link to a Tax Research product.  

Entering Data 
Entering data on the forms is made easy.  

If an amount is a round figure, there is no need to enter the cents (“.00”). The program will do 
it for you. 

If an amount is a negative number, precede it with a “-”. 

Data can be entered into overrideable cells, simply by entering the data. The program will 
prompt you to confirm the override before displaying the amount. 

Special Forms 
Multiple copy forms  
There are a number of tax forms for which you may require several copies. For example, on 
the data entry screens for beneficiaries, you will require a separate copy for each beneficiary 
or the trust. 

For these forms, Taxprep allows you to create multiple copies of the forms. A Multiple Copy 
toolbar appears at the top of each multiple copy form to simplify navigation between copies.  

 

 Displays the first copy of the form. 

 The Previous button displays the previous copy, and the Next button displays the 
next copy of the form. 

 Displays the last copy of the form. 

 The Copies list provides access to all the copies that have been created. 

 The New button creates a new copy of the form and the Delete button deletes the 
copy displayed on the screen. 

The Search button allows you to search for a specific copy of the form by entering 
any part of the description. 
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Attachments 
You can create both attached notes and attached schedules. Once a note or schedule has 
been attached to a cell, a paper clip will be displayed in the left corner of the cell. 

 

Attached Notes 
You can attach a note to any type of cell by right-clicking then selecting Attach Note or 
pressing Alt+F10. 

If you want the note that you create to be rolled forward to next year’s return (e.g. because 
the note may also be applicable next year), select the following option: 

 
When you hover your pointer over a cell that has an attached note, the note will appear. 

Attached notes are summarized on the Form Notes, Attached Notes - Summary (Jump Code: 
ATTN) which can be printed. The notes can be sorted according to the order the forms appear 
in the Form Manager. The name of the user that last edited the note, as well as the date the 
note was last modified, will be displayed on the Attached Notes – Summary. 

You can also navigate to a cell that has a note attached by double-clicking the name of the 
cell associated to the note from the Attached Notes – Summary. 

Attached Schedules 
The Attached Schedule With Total (Jump Code: ATTS) is a multiple copy form. Each time you 
attach a schedule to a cell, a new copy of the attached schedule is added to the form and 
linked to this cell.  

You can navigate to a cell that has the schedule attached by double-clicking the name of the 
cell associated to the note from the Attached Schedules. 

 TIP 
You can locate all 
cells that have 
attached notes 
using the filter 
“Cells with 
Attached Notes” in 
Xpress. 
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To attach a schedule: 

1. Select the cell to which you would like to attach a schedule. 

2. On the Edit menu, select Attach Schedule. 

You can also add copies that are not linked to any cell. 

For more information on the Attached Notes and Schedules, refer to the Help. 

Multi-Line Tables 
Some forms contain multi-line tables. For example, Schedule 1, Form T1141 and the Summary 
of Charitable Donations all contain these tables. 

A new line (or set of lines) is automatically added as soon as data is entered. 

You can also use the Add button to create a new line or lines. Use the Delete button to 
remove a line.  

Client Letters  
Previewing a Letter 
Letter templates are linked to letters on the Form Manager. When you print or display a letter 
from the Form Manager, the template contents is merged with the data in the active tax 
return. The resulting document is a letter that contains information specific to each client's 
situation. 

You can view the letter by entering the jump code for that letter preview similar to accessing 
any other form. 



Taxprep for Trusts  Quick Start Guide 

15 

 
Changing the Contents of the Letter 
You can change the contents of the client letter for a specific client in two ways: 

• Modify the data in the Client Letter Worksheet; or 

• Edit the Letter Preview. 

Modify the Client Letter Worksheet 
The Client Letter Worksheet (Jump Code: LW) is used to select and modify the information that 
appears in the client letters. It is also used to override which letters are applicable to the 
return. 

You can enter additional information for this return, such as the name of a specific 
partner/staff member to appear at the bottom of the letter in addition to the firm name. 

You can also enter optional opening and closing paragraphs specific to this return. 

Any data that you enter in the Client Letter Worksheet is saved with the return. 

Editing the Letter Preview 
You can edit the letter preview to temporarily change the letter generated from your 
template. You can add, delete or modify the text in the letter as well as pasting in text from 
another source (e.g. a Word document). However, the edit will only stay in effect while you 
are in the letter preview. The next time that you access the letter preview, your edits will be 
lost, as the preview will be regenerated from your template to ensure that it reflects the 
latest data in the return.  

You can, however, save your edited version of the letter preview to an .rtf file which is 
compatible with word-processing programs, using the command Save Letter As on the File 
menu. If you have edited the preview, Taxprep for Trusts will ask you if you want to save the 
edited preview when you leave the form. When the letter preview is saved, the program will 
give you the option of automatically opening the .rtf file in your word processing program.  

You can also print the edited letter preview using the Print Form command similar to any 
other form. 

Changing all Client Letters 
If you want to make a change for all of your client letters (e.g. change the wording of a 
specific paragraph, or add the firm logo to the letter), you can edit the appropriate letter 
templates.  

For information on editing the letter templates, refer to the Help. 
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Importing and Exporting  
Taxprep for Trusts allows you to import and export the following types of files:  

• .csv files (separator: semicolon). This file format contains items from a spreadsheet or a 
database with cells separated by semicolons and can be created with any type of text 
editor; 

• .xls files (worksheet). This type of file is created with Microsoft Excel©. 
• Personal Taxprep Data: When you print or transmit T3 slips, a database will be created 

automatically. This database will allow you to import the T3 slip data when you open the 
related tax return in Personal Taxprep.  

You can also synchronize contact information with CCH iFirm. 

Refer to the Help for more information. 

Creating a Taxprep Forms File 
You can use the command Create Taxprep Forms File on the File menu to create a Taxprep 
Forms file and copy the appropriate data from Form Identification, Trust Identification and 
Other Information (Jump Code: ID) to the Identification form of the new Taxprep Forms client 
file. 

This can be useful in situations where you need to prepare a form or information return that 
is only available in Taxprep Forms. For example, to generate a T4 slip to report Executor fees 
paid by the trust. 

You can also create a Taxprep Forms client file from the Client Manager. 

Once the Taxprep Forms file has been created, Taxprep Forms will launch automatically so 
that you can prepare the required forms or slips.  

Note: You must have Taxprep Forms installed in order to use this feature. 
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Saving Returns 

You must click the Save icon to save the data. If you attempt to close the return while 
there is unsaved data, Taxprep for Trusts will prompt you to save the file prior to closing it.  

Taxprep for Trusts will also automatically save periodic back-ups of your data files if they 
contain any unsaved data. You can modify the interval at which the backup files are saved in 
Options and Settings. 

The file extension indicates the taxation year: .325 for a taxation year ending in 2025 and .326 
for a taxation year ending in 2026. 

Notes to the File 

 

When you save a file, by default 
Taxprep will display the 
Properties dialog box. This 
includes a section for notes that 
can be used to record 
information about the return.  

These notes can be edited and 
viewed in the Client Manager. 
When rolling forward your files, 
you also have the option to roll 
forward these notes. 

Attaching External Files 

You can attach any external file to your tax return file by clicking the  icon on the 
toolbar or the Attached Files command on the File menu. This dialog box is also accessible by 
pressing Ctrl+F11. 
You have the option of either saving a link to the selected file or embedding a copy of the 
selected file within the Taxprep data file.  
While almost any type of file can be attached, you cannot attach file types that are 
executable and could therefore present a security risk (e.g. .exe, .bat, .chm, .js). 
Attached files are not transmitted with the return.  
For more information on attaching external files, refer to the online help. 



Taxprep for Trusts  Quick Start Guide 

18 

Reviewing Returns 
Once you have entered all of the information into the tax return, you should review the 
return to ensure accuracy. There are several ways of reviewing the return: 

Xpress 
Taxprep Xpress can also be used to review and verify data. It offers many filters that enable 
you to, among other things, compare the values entered for this year with those from last 
year. This way you can quickly notice errors or missing information. It also allows you to 
review overridden and marked cells in the return by selecting the appropriate Xpress filter. 

Track Changes 
During the review process, you may wish to monitor any changes made to the return to 
ensure that only the identified corrections are made and that no data is changed 
inadvertently. 

Activate the command Track Changes on the Edit menu and any changes made to the return 
after that point will be tracked and can be viewed in Xpress using the filter “Data Modified 
after activating Track Changes.” 

Monitor 
The monitor is a tracking tool that lets you display key tax information at the bottom of the 
tax return window.  

On the View menu, click Monitor to display or hide the monitor. 

 
Certain values will be displayed in the Monitor by default: Total income allocated, Net 
income, Taxable income, Total taxes payable, Balance due or refund, Excess AMT over regular 
tax. However, you can customize the Monitor’s contents by adding and removing cells as well 
as adjusting their descriptions, width and display order. 

To add a cell to the Monitor, simply click the cell that you want to view and drag it onto the 
Monitor. 

When you customize the Monitor’s contents, these settings are saved for your workstation 
and will apply to all returns. 

Diagnostics 
You can display the list of diagnostics so that you can consult them as you work on the 
return. 

To view the list of diagnostics, click Diagnostics on the View menu, or click  on the 
toolbar. 

You have two options for displaying the diagnostics: Dock and Float. 

If you choose Dock, the list of diagnostics will be displayed in a pane at the bottom of the 
Taxprep window.  

If you choose Float, the diagnostics will be displayed in a separate window which you can 
reposition (e.g. onto a second monitor). 
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You can also use the hotkey Alt+F5 to display the docked list of diagnostics and the hotkey 
Alt+F6 to display the floating list of diagnostics. Alternatively, you can access the 
Form Manager and enter the Jump Code DIAG to display the Diagnostics. 

Once the Diagnostics are displayed, you can switch between display modes using the 
icon on the Diagnostics toolbar. 

To display diagnostics directly on a form, point to a cell with a diagnostic’s indicator and the 
diagnostic message will be displayed. This information is available regardless of whether or 
not the diagnostics pane is visible. 

Diagnostics can be printed directly from the Diagnostics pane (either floating or docked) 
using the command File/Print Diagnostics or they can be included in a print format so that 
they are printed along with the return. By default, the diagnostics will be printed in the 
“Office” copy of the return. 

Customized Diagnostics 
You can also create your own diagnostics in Taxprep in the view Filters and Diagnostics. 
These diagnostics can be used to check for adherence with firm procedures (e.g. partner 
name entered) or as a reminder for specific data entry requirements or tax issues.  

In addition, for most items identified in our Troubleshooting memo, a customized client 
filter/diagnostic may be downloaded in order to assist in identifying returns affected by the 
problem. These diagnostics will appear on the tab My Diagnostics along with any applicable 
customized diagnostics you have created.  

Refer to the Help for more information on how to create custom diagnostics. 

 

Review Mode 
When a return is being reviewed, the review mode allows you to add review marks to the 
appropriate cells in the forms simply by clicking them. 

Review marks can be used to identify whether the data is correct or incomplete.  

The following review marks are available:  

Symbo
l 

Name of the 
review mark Recommended when... 

 First review The reviewer wants to indicate that the content of a cell has 
been reviewed once. 

 
Second 
review 

The reviewer wants to indicate that the content of a cell has 
been reviewed a second time. 

 Error The reviewer wants to let a preparer know that the content of 
a cell contains an error. 

 Uncertainty 
The preparer wants to indicate that he or she is uncertain of 
the content of a cell. This mark can also be used to represent 
an estimate. 

 
Other  

The preparer wants to indicate that the content of a cell must 
be reviewed for a reason other than the one previously 
mentioned.  

Note: If you double-click a cell when the review mode is activated, a review mark is added 
and then you can access the source form. 

 TIP 
The review mode 
can be used from 
the Xpress tool. 

 

mk:@MSITStore:C:%5CProgram%20Files%5CCCH%5CT1%20Taxprep%202006%5CHelp%5CTP1%5CTxpTechE.chm::/ReviewMarkAdd.htm
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Review marks are not printed when you use the Print Return command. Review marks can be 
printed using the Print Form command by using the print option Print as displayed. 

Reviewing Diagnostics 
You can mark diagnostics as “Reviewed” or “Ignored” by right-clicking on the diagnostic in 
the Diagnostics pane and selecting the desired annotation.  

By default, all diagnostics will appear under the Take Action tab in Diagnostics pane. 
However, once a diagnostic is marked as Reviewed or Ignored, it will no longer appear under 
the Take Action tab but will instead be shown in the Reviewed or Ignored tab, as applicable. 

This allows you to mark any diagnostics that cannot be cleared (e.g. a filing reminder), so that 
upon subsequent review, you will know which diagnostics you have already reviewed. 

Printing 

Printing Forms 
Individual Forms 
In the Tax Return view, you can print individual forms for any of the active returns.  

1. On the File menu, click Print Form to print the current form that is on screen.  

Note: When you use the Print Form command on a multiple copy form (e.g. Form T776), only 
the current copy will be printed. To print all copies of a multiple copy form, select the entry 
on the Form Manager and then click Print Selected Form(s).  

Multiple Forms 
To print more than one form at the same time (but not necessarily the whole return): 

1. Select the forms on the Form Manager.  

2. On the File menu click Print Selected Forms. 

3. Click OK to start printing. 

Note: When viewing a form, the print command is called Print Form. When on the Forms 
Manager, the print command is called Print Selected Forms. 

Form Printing Options 
You can select a number of options when printing individual forms: 

• Print to PDF file 

• Print a blank copy of the selected form(s) 

• Print the form as displayed on the screen 

• Override the date to be printed on the form(s) 

• Page range to be printed (single form only) 

• Print a watermark on the form(s) 

• Use zoom printing to print more than one page per sheet of paper 

• Select the language in which the form will be printed 

You can also click the Options button to modify any of the print settings previously 
configured under Options and Settings or to select PDF file options. 
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Printing Returns 
You can print the return by clicking Print Tax Return on the File menu.  

Viewing Diagnostics 

When you use the Print Tax Return command, and there is at least one diagnostic that needs 
to be corrected, the diagnostics will be displayed automatically prior to printing.  

Click Continue if you want to proceed with printing the return.  

Selecting Returns 

 
The federal and Québec returns in the current client file will be displayed. You can select 
which returns you want to print. 

Note: The selection of what will be printed for each copy of the return is saved in a template 
file called a “Print Format.” For more information on customizing print formats, refer to the 
Help. 

All of the available print formats will be listed. You can change which print formats are 
selected by clicking the adjacent check box.  

All selected print formats will be produced for each return. (e.g. a client copy, a government 
copy and an office copy will be printed).  

If you want to generate a PDF file instead of printing a hard copy, click the PDF box.  
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You can select a different watermark for each copy. 

Click Options to change any of your configured print options prior to printing.  

PDF Printing 
When generating PDF files, you can apply a password automatically to the generated PDF. 
This helps ensure that the returns remain secure (e.g. when sending copies via Email). You 
can also configure the file naming convention for the PDF files generated. These options can 
be configured in advance using the command Options and Settings on the Tools menu, or 
immediately prior to printing using the Options button in the Print Return dialog box. 

Printing Returns from Multiple Files 
If you want to print returns from multiple data files, select the returns on the Client Manager 
then click Print Tax Returns as you would for a single file. 

Printing T3/NR4/RL-16 slips 
There are different ways to print T3, NR4 and RL-16 slips to issue to beneficiaries.  

Print Return 

If you are using the Print Return command, the slips selected for filing (T3S, NR4 or QR16) will 
be printed depending on the selected printing method (for example, if you want to print T3 
slips on preprinted forms, select the Govt-Pre print format). 

Print Selected Forms 
The Print Selected Forms command also allows for the printing of slips. You can print copies 
of the beneficiaries' T3, NR4 or RL-16 slips while they are displayed or you can print all copies 
of the slips selected for all beneficiaries of the trust from the Form Manager.  

Print Slips 
Finally, you can use the specific Print Slips command. The main difference between this print 
command and the print commands used for returns and forms is that you can print a single 
type of slip having a specific type of data. For example, with the Print Slips command, you 
can print the T3 slips with the "Original" type only. This print method allows you to print slips 
for the active client file or for several client files, by selecting them from the Client Manager.  

Note that the choice to submit the slips electronically will have an impact on printing. For 
example, when slips are being submitted electronically, copy 1 of the slips is not required 
and does not need to be printed. Furthermore, in the case of RL-16 slips, the electronic 
transmission file must be generated before printing occurs since slip numbers are printed on 
these slips when the transmission file is created.  

Printing Slips to PDF 
When you select the PDF option within any of the above-mentioned commands, you have the 
option to generate a separate PDF file for each slip and automatically assign a password to 
that file, if applicable. This can be configured on the PDF tab of the Options dialog box or in 
advance in the Print – PDF Files section of Options and Settings. 
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Electronic Signatures 
You can use an electronic signature on prescribed forms such as the T183 TRUST and T1135, as 
well as on the Form AUT-01, Authorize a Representative for Access by Phone or Mail and other 
forms that may require a signature.  

If your client will be electronically signing Form T183 TRUST, Information Return for the 
electronic filing of Trust Return, answer Yes to the question Are you planning on using an 
electronic signature method on Form T183? on the form and provide the e-signature date and 
time in the fields indicated. This information will be transmitted with the T3. The answer to 
the e-signature question can be defaulted in Section F, EFILE information, on the PROFILE tab 
in the Preparer Profile.  

Note that if your client physically signs the T183 TRUST and sends you a scan or image of the 
form, the CRA does not consider that to be an electronic signature.  

If you are using CCH iFirm Portal, you can take advantage of the built-in tags for e-signatures 
that have been integrated into various forms. These tags will indicate where the digital 
signature must be affixed allowing you to streamline the publishing of forms that require 
your customer’s digital signature.  

For more information, refer to the Help Centre for Taxprep for Trusts and/or the Help Centre 
for CCH iFirm Portal. 

Electronic Filing 
Taxprep for Trusts supports two different types of electronic filing. The T3, NR4 and RL-16 
slips and summaries can be electronically filed to the CRA and Revenu Québec in an XML 
format via Internet File Transfer.  

The T3 returns and T1135 forms, however, are transmitted to the CRA using the T3 EFILE web 
service. Note that the T3 slips and T3 Summary are not part of T3 EFILE and must be filed 
using Internet File Transfer.  

Note: Revenu Québec does not yet accept electronic filing of TP646 returns.  

Mandatory Electronic Filing 
Electronic filing of the slip information is mandatory where there are 5 or more slips. Each T3 
or NR4 slip is an information return, and the penalty the CRA assesses for paper-filing is 
based on the number of information returns filed in an incorrect format. The penalty is 
calculated per type of information return (i.e. T3 vs. NR4). 

In addition, T3 returns are subject to mandatory EFILE when a professional preparer files 
more than 5 T3 returns per calendar year. However, tax preparers may paper-file up to 5 
returns without penalty. 

Preparing for Electronic Filing 
Select the T3 Return and Slips for EFILE 
You can select whether or not you want to electronically transmit the T3 return, T3 slips, NR4 
slips and RL-16 slips at the top of the Form Electronic Filing (Jump Code: EFILE).  
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To select EFILE by default for the T3 returns, T3 slips, NR4 slips or RL-16 slips, you can choose 
the option(s) provided in the “EFILE information” section of the Preparer Profile. 

T3 Return Eligibility  
Form Electronic Filing will indicate if the T3 return is subject to any of the exclusions. Only 
original T3 returns can be transmitted. Amended and cancelled returns must be paper-filed.  

Form EFILE – T3 Return Summary of EFILE Data Fields (Jump Code: EFILE SUM) will show the 
data that will be transmitted to the CRA for the forms indicated. In addition, Forms SFD T776, 
SFD T2042 and SFD T2125 will display the data that will be transmitted to the CRA for the 
rental, farming and business schedules. 

Note that due to the potential size of the beneficial ownership data transmitted for Schedule 
15 of the T3 return, Schedule 15 is not yet included on Form EFILE SUM. 

Nevertheless, if Schedule 15 is applicable to the return, the data will be transmitted as part of 
T3 EFILE. This will be indicated at the top of Schedule 15.  

 

Verify Eligibility of Slips for Electronic Transmission 
When electronic transmission has been selected for the slips in a return, the program will 
determine if each slip is then eligible for electronic transmission (T3, NR4, RL-16). 

The EFILE status of a slip is “Eligible” when electronic transmission is selected, and the client 
file: 

• includes at least one of the slip types in question; and 

• meets eligibility requirements. 
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To verify that the slips in the client file meet the eligibility requirements for EFILE, proceed as 
follows: 

1. Display the Diagnostics. 

2. Click the EFILE tab to verify any EFILE diagnostics. 

If the slips in the client file meet the eligibility requirements for EFILE and no EFILE diagnostic 
is issued, the EFILE status for the T3, NR4 and RL-16 slips will then be “Eligible” and the 
following diagnostics will display: 

 
 

Errors detected  
Errors that can cause rejection of the return are indicated in the diagnostics under the EFILE 
tab. They must be corrected in order for the slips to be eligible for EFILE purposes. 

T3 EFILE 
Registered EFILERS can electronically file eligible T3 returns in a similar manner to 
electronically filing a T1 or T2 return.  

EFILE Registration 
In order to electronically file T3 returns, you must select T3 as one of the types of returns you 
will be transmitting when you renew your EFILE account. If you have already renewed your 
EFILE account, you can change this information online by logging into your EFILE account on 
the CRA Web site.  

Starting in February 2026, the CRA will implement a process that associates EFILE accounts 
with specific certified T3 software products. This enhancement is designed to strengthen the 
security of return submissions by ensuring that EFILE users submit their returns through the 
specific software product(s) associated with their EFILE account. 

For existing EFILE accounts, the CRA will automatically associate your EFILE account to your 
preferred software product(s) based on your historical usage. However, if you have recently 
switched from another T3 program to Taxprep for Trusts, please contact your EFILE helpdesk 
to ensure that they have the correct software product registered. New EFILE registrants will 
be contacted by the EFILE helpdesk to confirm the software product(s) they will be using. 

Beginning in February 2026, if a T3 return is submitted using a different software product than 
the one(s) linked to your EFILE account, the return will be rejected, and the transmission will 
fail. 

EFILE Number and Password 
In order to electronically transmit T3 returns, you must enter your EFILE number and 2026 
password in the Identification – EFILE screen under Tools/Options and Settings/Electronic 
Services. 
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T183 TRUST 
Prior to transmitting a T3 return, your client will need to sign Form T183 TRUST, Information 
Return for the electronic filing of Trust Return (Jump code: T183) authorizing the transmission.  

Trust Number 
You will also require a trust number for the trust. You can apply for a trust account number 
using the Trust Account Registration service within My Account, My Business Account, 
and Represent a Client. 

Exclusions 
The following types of T3 returns are excluded for the 2026 EFILE program:  
• A T3 return for a tax year that ends before 2021  

• An amended T3 return 

• A T3 return for a trust that does not have a trust account number or cannot provide one 
in the electronic file  

• A T3 return for a trust that is filing Form RC199, Voluntary Disclosures Program (VDP) 
Application, or the taxpayer is making a request under the Voluntary Disclosures Program  

• A return for a trust claiming bankruptcy in the year 

In addition, returns containing the following forms are also excluded:  
• Form T1273 Statement A – Harmonized AgriStability and AgriInvest Programs Information 

and Statement of Farming Activities for Individuals and Form T1163 Statement A – 
AgriStability and AgriInvest Programs Information and Statement of Farming Activities for 
Individuals are excluded from T3 EFILE.  

• T3SK CG – Saskatchewan Farm and Small Business Capital Gains Tax Credit (Trusts) 
• T3 NB-SBI – T3 New Brunswick Small Business Investor Tax Credit  

• T3PFT – T3 Provincial or Territorial Foreign Tax Credit 

• T2223 – Election Under Subsection 159(6.1) of the Income Tax Act By a Trust to Defer 
Payment of Income Tax (new exclusion this year) 

Similar to a T1 return, returns with the following situations are excluded: 
• Business income tax paid to more than three foreign countries  

• Non-business income tax paid to more than three foreign countries  

• More than 12 Selected Financial Data (SFD) records 

Additional EFILE Questions 
The CRA requires certain additional information to be transmitted when a T3 return is filed 
using T3 EFILE. Review the section Questions used for EFILE only at the bottom of the ID form 
(Jump Code: ID).  

Transmitting Returns 
A return can be electronically transmitted from either the Tax Return view or the Client 
Manager view. In the Tax Return view, you can only transmit the returns contained in the 
active client file. In the Client Manager view, you can select returns from multiple client files 
for electronic transmission. 
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Transmitting the Active Return 
1. On the Transmission menu, click General and Specialized Returns, and then click 

Transmit.  

2. Click OK to transmit the return.  

Transmitting Multiple Returns 

1. Click the  button, then select Client Manager. 

2. Click  on the tool bar, and then select the filter for the type of return you wish to 
transmit (e.g. T3 Return EFILE Eligible). 

3. Select the return(s) that you want to transmit.  

4. On the Transmission menu, click General and Specialized Returns, and then click 
Transmit.  

5. In the Transmit dialog box, verify the returns that you want to transmit. You can remove 
any returns from the list by removing the check mark beside the return. If a return is 
selected that is not EFILE Eligible, no check mark will appear beside that return and you 
will be unable to select it for transmission.  

6. Click OK to transmit the return.  

Transmission Results 
Once the returns have been transmitted, a dialog box will appear with the transmission 
results. It will list the returns that have been transmitted and provide a confirmation number 
for each accepted return or an error message for any rejected returns.  

Use the Print button at the bottom of the dialog box to print the list for your records. You can 
also view these results at any time by clicking EFILE Transmission Results on the 
Transmission/General and Specialized Returns menu. 

The transmission results for each return are also recorded in Form EFILE Information (Jump 
Code: EFILE INFO). If CRA accepts the return for processing, then the program will 
automatically change the EFILE status to “Accepted.” 

Re-transmitting Rejected Returns 
If a return is rejected, this will be indicated in the EFILE Transmission Results dialog box 
along with the error clue provided by the CRA and Taxprep will automatically change the 
EFILE status of the return to “Rejected.”  

The error message for a rejected return can be viewed on Form EFILE Information, (Jump 
Code: EFILE INFO) within that return or using the EFILE Transmission Results command.  

To avoid another rejection, ensure that you have corrected all the errors indicated by the tax 
authorities prior to re-transmission. Taxprep will automatically change the EFILE status back 
to “Eligible” when the return is recalculated.  

Supporting Documents 
All elections, designations, agreements and waivers, including the supporting documentation, 
must be submitted to the CRA in writing or through the Submit documents online service. In 
order for an election to be considered valid, it must be submitted by the due date 
established in the Act. 
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Electronically transmitting the T1135 Foreign Income Verification Statement 
If a trust owns or holds foreign property at any time during the year with a total cost of more 
than CAN$100,000, then the trust is required to file a T1135, Foreign Income Verification 
Statement (Jump Code: 1135).  

Taxprep for Trusts supports the electronic filing of the T1135 for trusts for tax years that begin 
on or after January 1, 2024.  

The T1135 can be filed in paper format or electronically: there is currently no legislative 
requirement to electronically file a T1135 information return.  

The T1135 is transmitted separately from the T3 return. However, in Taxprep for Trusts, we 
have implemented the electronic filing of the T1135 so that you can transmit both the T3 and 
the T1135 at the same time.  

Alternatively, you can transmit the T3 without the T1135 or the T1135 without the T3. 

Note that for 2025, Québec has introduced parallel reporting of foreign property for Québec 
filers. However, new Form TP-1079.8.BE, Foreign Property Return, cannot be filed 
electronically by a trust or partnership.  

T1135 EFILE Status 
Similar to T3 EFILE, a T1135 must be selected for EFILE in order to be eligible for EFILE. In the 
Preparer Profile, you can choose to have all of your T1135s selected for EFILE automatically. 

Provided all the required data has been completed, if the T1135 is selected for EFILE, then the 
EFILE status of the form will become “Eligible”. This will be indicated in the Electronic Filing 
section at the top of the form. The information on the transmission status of the T1135 is also 
available using the File/Properties command (F11). 

Transmitting the T1135 
The T1135 is transmitted using the same command that you use for transmitting T3 returns 
(i.e., the command General and Specialized Returns/Transmit in the Transmission menu). 

If you have selected at least one client file that includes a T1135 with the EFILE status 
“Eligible”, then the column for the T1135 will be displayed in the Transmit dialog box. 

By default, all of the eligible T1135 forms will be selected for transmission. 

Clear the boxes for the T1135 forms you do not want to transmit. 

If a selected return does not contain an eligible T1135, the T1135 check box will not be 
selected and you will be unable to select the check box. 

Similarly, if you wish to transmit a T1135 for a trust for whom a T3 has already been filed, you 
will be unable to select the T3 check box. For more information on electronically filing a 
T1135, refer to the Help. 

Transmitting Slips 
Note that the T3 and NR4 slips and summaries are not transmitted with the T3 return – they 
must be submitted separately. 

Configure the Program 

Define Transmission Options by Default 
The program allows you to define the options to be used by default for each slip 
transmission. To modify these options, proceed as follows: 

1. In the Tools menu, click Options and Settings. 
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2. Under Electronic Services, click General. 

3. The generated slip transmission files will be saved in the folder indicated under Select 
the location to save the generated XML files:. If you want to change this location, click the 

 button and select the desired folder.  

4. The Internet portal of the CRA or RQ will automatically display during transmission. If you 
want to generate the file for Internet, but access the Internet yourself at a later date, 
clear the check box Display portal after creating file.  

5. Click OK to save changes. 

Enter ID Information 
The tax authorities require detailed information concerning the identification of the slip 
transmitter. The required information differs depending on whether the slips are transmitted 
to the CRA or RQ.  

For federal transmissions, a transmitter account number must be included in the 
transmission file. A Web access code (WAC) is also required to log into the Internet File 
Transfer service. This WAC must be associated with the transmitter’s account number. 
Entering the WAC in the Electronic Services > Identification settings is optional. If it is 
entered, then the program will display the WAC in the window that appears to the left of the 
CRA’s Internet File Transfer service login screen to assist you in accessing the service. 

To enter this information in the program, proceed as follows: 

1. In the Tools menu, click Options and Settings. 

2. Under Electronic Services, click Identification - Generated. 

3. In the Identification section, click the  button, and enter the information concerning 
the transmitter and the resource persons.  

4. If you are transmitting slips to the CRA, click Federal, and enter the required information.  

5. If you are transmitting slips to Revenu Québec, click Québec, and enter the required 
information.  

6. Click OK to save the changes.  

Note: The mandatory information is identified by a red triangle in the upper right corner of 
the fields.  

Enter Slip Numbers 
If you are filing RL-16 slips, you must enter in the program the range of numbers assigned to 
you by Revenu Québec. When the file to transmit is generated, the program will assign a 
unique number to each RL-16 slip filed.  

Note: If there are multiple users responsible for generating RL-16 slips and you are not using 
the Network version, you will need to ensure that there is no duplication of slip numbers. 
You may therefore want to distribute the assigned number range among the staff responsible 
for generating the RL-16 slips. 

To enter the range of slip numbers, proceed as follows: 

1. On the Tools menu, click Options and Settings. 

2. Under Electronic Services, click Slip Numbers. 

3. In the First box, enter the first number in the range.  

4. In the Last box, enter the last number in the range.  
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5. In the Next Number box, the program automatically indicates the next number that will 
be used according to the numbers already attributed to slips. If you want, you can 
manually enter the number you want the program to attribute to the next slip.  

6. Click OK to save changes. 

Note: RQ requires that these numbers appear on the printed slips. Therefore, you must 
generate the RL-16 slips before printing them, in order for the program to assign the 
numbers.  

Transmit Slips 
The program allows you to transmit slips for one or more client files at the time. However, all 
of the slips being transmitted together must be the same type (e.g., T3 or NR4 but not both). 
Before completing the transmission, you can display the list of all slips that will be 
transmitted. In case of errors or problems preventing the transmission of slips, the program 
will inform you of the problem to correct.  

Transmit slips for a single client file  
To transmit slips for a single client file, proceed as follows: 

1. Open the client file in the Tax Return view, or select the client file in the Client Manager.  

2. In the Transmission menu, click Transmit Slips. 

3. Select the slip and the type of data to transmit.  

4. Click OK to generate the file to transmit. 

 

Transmit slips for several client files 
If you select several client files, the slips will then be transmitted together in the same 
transmission file. To transmit slips for several client files, proceed as follows: 

1. Select the client files in the Client Manager. 

2. In the Transmission menu, click Transmit Slips. 

3. Verify the client files that you want to transmit. You can remove a client file from this 
operation by clearing the box next to the client file.  

4. Select the slip and the type of data to transmit.  

5. Click OK to generate the file to transmit. 

Display slips to transmit 
From the Transmit Slips dialog box, you can display a list of slips that will be included in the 
transmission for each client file selected. To display this list, click the scroll down list under 
the Details column.  

• It is possible to sort the list of slips by clicking the header of the desired column.  

• You can enter characters to search for an element of the list.  

• If a slip has already been generated, the Date – Type of data column appears in the list 
and indicates the date on which the creation took place.  

• To display all slips contained in the client file, rather than only the ones to transmit, clear 
the Display only slips to transmit option. 

Note: If the slips in the client file cannot be selected for transmission because of an error, it 
is not possible to display a list of these slips. 
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Consult Error Messages 
If an error prevents selection of the slips in a client file, a red triangle will be displayed under 
the Details column of the Transmit Slips dialog box. To display the error details, place the 
cursor over this indicator. An error could occur, for example, in the following cases: 

 You cannot transmit the selected slip because EFILE diagnostics exist; or 

 The client file does not contain any slip that corresponds to the selected type of data (for 
example, you have selected “Amended”, but the client file only contains “Original” slips).  

In case of an error, it is not possible to transmit the slips in the client file. Please correct the 
problem indicated by the program. 

 

Creation of the File(s) to Transmit 
When you click OK in the Transmit Slips dialog box, the program creates the file to transmit 
in one of the folders specified in the Options and Settings. By default, the folders are as 
follows:  

• \...\My Documents\Wolters Kluwer\T3 Taxprep 20**\Generated Slips\T3 
• \...\My Documents\Wolters Kluwer\T3 Taxprep 20**\Generated Slips\NR4 
• \...\My Documents\Wolters Kluwer\T3 Taxprep 20**\Generated Slips\RL-16 
The name of the saved transmission file is AABBBBBBCCCvariable.XML, where AA represents 
the taxation year, BBBBBB represents the transmitter number and CCC is a counter for each 
file produced. The variable that follows the number can be either the name of the tax filer 
(where a single client file is transmitted), or the number of transmitted files (where several 
client files are transmitted).  
Note, however, that the total number of characters in the file name cannot exceed 30. 
The saved file will remain in the folder and will not be deleted. 

Internet Transmission Help Window 
When you transmit, a window will display to the left of the CRA or RQ portal. It will display 
various information that will assist you in uploading your file. Once your file has been 
successfully uploaded, you can enter the confirmation number provided. This number will 
then be transferred to the relevant client file. 

CRA Error Checking 
When an .xml file is uploaded to the CRA, the CRA will perform an electronic filing validation. 
For smaller files (2MB or less), this is done online at the time of submission. If no errors are 
found, a confirmation of receipt page will appear. If errors are found, then an error report will 
appear. The error report can contain both warnings and errors. It is recommended that, if 
errors have been identified, you cancel the upload process, correct the errors and resubmit 
the entire file.  

For larger files (greater than 2MB), the validations will be done offline (i.e. after the file has 
been submitted). If errors are found, a CRA agent may contact the filer. An error may result in 
an information return being rejected, in which case the return would need to be resubmitted.  

EFILE Status  
Once the creation of transmission files is completed, the program will automatically assign 
the “Generated - <Type of data>” to the EFILE status of each type of slip that was transmitted.  
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For example, if you have transmitted “Amended” RL-16 slips, the EFILE status will be 
“Generated – Amended.” You can consult this status from several places in the program, such 
as the Properties dialog box for the client file as well as in the Client Manager. 
Note: A slip type with a “Generated” status can be transmitted again, if necessary, since the 
program continues to validate its eligibility to EFILE even after transmission.  

Amending Slips 
If you amend slips, then you should file the amended slips using the same filing method you 
used with the original slips (i.e. if the original slips were paper-filed, then you should paper-
file any amended slips). 

EFILE Information Form (Jump Code: EFILE INFO) 
This form provides easy access to EFILE transmission information within the client file, 
regardless of who transmitted the data. The EFILE Information form will indicate the name of 
the document being transmitted (e.g. T3 return or T3 slips), the type of data, the transmission 
date, the number of slips and the confirmation number.  

When transmitting T-slips, the program automatically updates the information on this form 
when the following three actions are carried out: 
1. A T-slip or RL slip is electronically filed; 
2. A confirmation number is entered by the user before the government’s portal is closed; 
3. The transfer of the confirmation number to the client file(s) is confirmed by the user. 
  

FILE History 
The EFILE transmission history displays the list of returns for which slips or a T3 return have 
been transmitted from the Client Manager.  
You can use this list to generate a report or retransmit slips, where problems have occurred.  
Note: This history is not produced if the transmission is done from an active return.  
For more information regarding electronic filing, refer to the Help. 

Help 
The following Help resources are available in the program: 

Tax and Form Help 
Context-sensitive tax help is easily accessible from each cell by pressing F1 or by clicking 
Taxprep for Trusts Help on the Help menu. 

The Help Centre is online and requires Internet access. The Help Centre includes information 
about using the program, completing the tax forms, electronic services, FAQ’s, 
Troubleshooting and Release Notes. It also includes links to many CRA and Revenu Québec 
guides. 

Knowledge Base  
Our Knowledge Base contains an array of articles answering technical and tax questions most 
frequently asked to our Support Centre agents. When you enter a few key words in the Search 
field, articles will be displayed in order of relevance, providing you with valuable information 
that will accurately answer your questions. You can use the filters on the left side of the 
screen to filter the results by product.  
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You can access the Knowledge Base from the Help Centre or directly from the 
Professional Centre. 

InfoConnect Tax Hints 
Cells with a blue triangle in the bottom right corner have a direct link to a relevant section in 
the appropriate Tax Research title, such as Preparing Your Trust Tax Returns or the Income 
Tax Act. 
If you have a subscription to the applicable Wolters Kluwer Tax Research title, and you have 
this option enabled, then when you hover your pointer over the cell, an InfoConnect tax hint 
will appear displaying the relevant tax hint. The tax hint consists of an excerpt from a tax 
research product. You can then click the Learn More link at the bottom of the hint to access 
the full topic in CCH AnswerConnect®.   

 
You can also view the InfoConnect tax hint by clicking the Tax Research button on the toolbar 
or by pressing Shift+F1. 
The display of InfoConnect can be enabled under Tools > Options and Settings > Options > 
Tax Research.    
The display of the InfoConnect tax hints can be disabled by clicking Hide at the bottom right 
corner of the hint. 

Technical Help 
To get help on the operation of the program (as opposed to the tax forms), access the Help 
Centre by clicking Taxprep for Trusts Help on the Help menu and then use the Search 
function to find relevant help topics. You can also click the Help button in the various dialog 
boxes. 

Virtual agent 
You can also obtain assistance using the advanced virtual agent.  

Click the Virtual Agent button located in the top right corner of the program. 

 
The virtual agent provides: 
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• Direct descriptive answers to your queries based on our knowledge base articles, 
allowing you to benefit from an efficient virtual conversation 24 hours a day, 7 days a 
week. 

• The ability to chat with a live agent during business hours, so you can discuss your 
question with a person in real time. 

• The option to submit a support case  

Note that you must register for the Support Platform to access your requests and be able to 
follow up on them. 

Training 
You can find information about current training opportunities by clicking Get Taxprep 
Training on the Help menu. 

 

https://support.cch.com/oss/canada/kb/solution/000268188?language=en

	Table of Contents
	Overview
	Different Views

	Setup
	Options and Settings
	Preparer Profile

	Preparing Returns
	Roll Forward
	Opening Files
	Client Manager
	Starting a New Return
	Accessing Forms
	Cell Display
	Special Forms
	Client Letters 
	Importing and Exporting 
	Creating a Taxprep Forms File
	Saving Returns

	Reviewing Returns
	Xpress
	Track Changes
	Monitor
	Diagnostics

	Printing
	Printing Forms

	Electronic Signatures
	Electronic Filing
	Preparing for Electronic Filing
	T3 EFILE
	Transmitting Slips
	CRA Error Checking
	EFILE Information Form (Jump Code: EFILE INFO)

	Help
	Tax and Form Help
	Knowledge Base 
	InfoConnect Tax Hints
	Technical Help
	Virtual agent
	Training




