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Introduction 
Welcome to Taxprep Forms! 

This Quick Start Guide is designed to acquaint you with the Taxprep Forms program as well as 
to give you tips on how to use the program. This is not an in-depth guide; please refer to the 
Help any time for tax or technical assistance when you are in the program. For information on 
tax changes, please refer to the Release Notes for each version. 
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Overview 
Different Views 
The Taxprep Forms program is comprised of several different views that allow you to perform 
different functions within the program. 

 

Accessing Views 
 

The various views in the program are accessed using the Menu button.  

 
 
 
 
 
 

The Taxprep Forms Views 

 
The Professional Centre provides important information about the program, tax 
news and links for customer service and support. 

 

The Client Manager displays all of your client files. You can use it to open and 
roll forward files, print client files, EFILE slips, create reports and perform other 
functions that help you to manage the tax preparation process. 

 
The Forms view is where you prepare the client files. You can print the tax client 
files or transmit the slips of the active client file. 

 
The Print Formats is where you define the print settings for each form included 
in the client file, such as the number of copies and the printer selection.  

 
The Preparer Profiles is where you enter data that you want by default in every 
client file. 

 

The Filters and Diagnostics view contains predefined and customized filters and 
diagnostics that you apply in the Client Manager or in the diagnostics pane to 
generate reports or to define certain situations. 

 
The Letters and Labels view is where you create customized templates for letters 
and labels. 

 
The EFILE Log lists all the transactions related to electronically filed client files 
and provides follow-up options and reports. 

 
The EFILE Archive stores archived transactions from the EFILE Log. 
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You can also access the views using 
the applicable shortcut key 
combinations. 

 

 
The name of the current view appears beside the Menu button.  

 

Toolbar 
The toolbar provides quick access to the most common commands in the program.  

 
The icons displayed on the toolbar will vary. For example, different icons will be displayed 
when you are viewing the Form Manager vs. when you are viewing a form.  

The toolbar icons will also vary from view to view, as some commands may not be applicable 
in all views.  
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The Professional Centre 
The Professional Centre is a dedicated Web page that provides the latest information on 
Taxprep Forms, including automatically alerting you to any program updates.  

On the Professional Centre you will see a link to the Help Centre and to support documents 
such as the Release Notes, as well as links to training resources and to the searchable 
Knowledge Base. The Professional Centre also provides information a link to submit a 
support ticket to the Customer Service and Support teams.  

For more information on the Taxprep Help Centre and the Knowledge Base see page 28.  

Default View 
By default, when you launch Taxprep Forms, the Forms view will be displayed. However, in 
Tools/Options and Settings (see below), you can configure the program to automatically 
open in the Client Manager or EFILE Log. 

Setup 
Options and Settings 
You can configure most aspects of the program using the Options and Settings command on 
the Tools menu. 

Note: If you are using the Network version, some options and settings may be pre-configured 
for various user groups. Check with your Network Administrator for more information. 

Click the section title to see a description of the options and settings contained in each 
section. Any changes that you make will be saved automatically when you click OK or Apply. 

Note: The options and settings are saved on your workstation and are unique to you. 

Preparer Profile 
Your preparer profile is configured in the Preparer Profiles view. You can have multiple 
Preparer Profiles.  

Click New to create a preparer profile. If you do not create a preparer profile, the program 
will use the defaults for the various options presented in the Preparer Profiles view. 

The Preparer Profiles edit screen has five tabs: Profile, Staff, Authorization Forms, Client 
Letter and Bill. 

Click the Profile tab to enter information about your firm and your preferences with respect 
to preparing and filing your client files. 

Click the Staff tab to enter the names of the staff and partners using Taxprep Forms for 
purposes of selecting these names in each client file for tracking purposes.  

Click the Authorization Forms tab to enter information and modify settings used when 
completing and filing the authorization forms. 

Click the Client Letter tab to configure your client letter options such as salutation, 
references to your firm, and customized opening and closing paragraphs. 

Click the Bill tab to configure your billing options in the Invoice Profile, including the 
standard charges for the detailed invoice. 

The first time you save a preparer profile, the program will display the Preparer Profile 
Properties dialog box. 

 TIP
When creating 
additional preparer 
profiles, you can 
make a copy of any 
existing profile and 
simply change 
selected fields. 
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You can enter a new name and description for your preparer profile. Click Default if you want 
that preparer profile to be used by default. You can change the information in this dialog box 
at any time using the Set Properties command. Click OK to return to the Preparer 
Profiles view. 

All of the profiles that you create will appear in the list of Preparer Profiles. A check mark will 
appear beside the default Preparer Profile. 

Refer to the Help for more information on the Preparer Profile. 

Preparing Client Files 
Roll Forward 
If your firm used Taxprep Forms or FormMaster last year, the files from the prior taxation year 
can be used to assist you in preparing your information returns and forms this year. You may 
also be able to roll forward files created using another forms program.  

In addition, you can roll forward files created with the current version of Taxprep Forms to 
facilitate preparing information returns for short year ends or to start entering data in 
advance of the release of the following year’s program.  

What is a Roll Forward? 
The roll forward procedure creates a new file for the current taxation year based on what was 
in last year’s client file to avoid re-entering information that was gathered in a prior year. 

When a file is rolled forward, the permanent information (e.g. client name, address, client ID), 
including recipient information is retained and the closing balances of any amounts rolled 
forward (e.g. Undepreciated capital cost allowance) become the opening balances.  

In addition, the data entered in the prior year file is retained for comparison purposes.  

Using the Roll Forward 
Roll forward of files can be done from the Client Manager and Forms views. To roll forward 
files from a single folder, proceed as follows: 

1. On the File menu, click Roll Forward. 

2. Click the drop-down list at the bottom right corner of the dialog box to select the type of 
file you wish to roll forward.   

 
3. Select the client file(s) from last year that you want to roll forward.  

4. Click Open. 

5. The Roll Forward dialog box will be displayed on the screen. In the File Options and Data 
Options tabs, select the desired options.  

6. Click OK to start the roll forward process. 

When a single file is rolled forward, it opens in the Identification form. 

 TIP
Rolling forward 
files from Multiple 
Folders 
If your prior year 
files are in different 
folders, you can use 
the Client Manager 
to view a list of all 
of last year’s files 
from multiple 
locations and select 
the files that you 
want to roll 
forward. 
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Opening Files 
To open an existing file, or a file that has been rolled forward, on the File menu, select Open. 
You can open as many data files as you want. 

You can open several client files at the same time using the Client Manager. Simply select the 
client files you want to open, then on the File menu, click Open. 

Opening Files Created with a Prior Version 
You can also open a file with a .T25 file extension created with Taxprep Forms 2024. When 
opening a prior version file, you will be given the option to recalculate the file using the 
current version. If you reply “No,” the file will open in “data locked” mode, and the data will 
be unchanged. Note that once the file has been saved in the current version, you will no 
longer be able to open the file using a prior version. 

Opening Prior Year Files Using Shortcuts 
When rolling forward the prior year client file, a shortcut to that client file will be 
automatically created. The shortcut will allow you to quickly access the prior year file. 

This shortcut will be available using the Prior Year/Open last year’s client file command on 
the File menu or by pressing Ctrl+E. It is also accessible by clicking the Prior Year icon on the 
toolbar and selecting a shortcut to a prior-year file. 

When you click the shortcut for the 2024 client file, it will be opened in the 2024 version of 
Taxprep Forms, provided it is installed and accessible. If you have rolled forward a 2024 file to 
2025 (e.g., for a short tax year of a partnership) clicking the shortcut to the 2025 file will open 
the file in the current version.  

You can also modify or delete existing shortcuts and manually create new shortcuts to other 
current year client files (e.g. shortcuts to client files for related parties). Once created, the 
shortcut will allow you to quickly access another client file. 

Client Manager 
The Client Manager provides information on all of your client files. 

It is used when you want to perform a function on multiple client files, such as: 

• Opening client files 

• Rolling forward data 

• Recalculating client files 

• Importing data 

• Generating reports on your clients 

• Printing client files 

• Printing slips 

• Printing letters and labels 

• Electronic filing 

The Client Manager is also a useful tool for easily locating the files that you want to open. 
You can sort your client files by any field and find a client file simply by typing the client 
name. 

For more information on the Client Manager, refer to the Help. 

 TIP 
Once you have 
finished work on a 
specific data file, 
close the file to 
avoid entering data 
into the wrong 
client file.

 TIP
In tables like the 
Client Manager and 
Form Manager, you 
can select items in 
several ways: 

• To select 
adjacent items, 
click the first 
item, and then 
press Shift while 
clicking the last 
item. 

• To select non-
adjacent items, 
click the first 
item, and then 
press Ctrl while 
clicking each 
item. 

• To select the 
entire list, click 
on the first item, 
and then press 
Shift and End 
simultaneously. 

javascript:kadovTextPopup(this)
javascript:kadovTextPopup(this)
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Starting a New Client File 
From the Client Manager or the Forms view, click New to start a new client file. 

Taxprep Forms will open in the Identification form. 

If you are using CCH® iFirm®, you can sync certain identification data between the Personal 
Taxprep client file and your client contacts in CCH iFirm. Refer to the Help for more 
information. 

Creating files from another Taxprep product 
If you use Personal Taxprep, Corporate Taxprep or Taxprep for Trusts, you can use the 
command Create Taxprep Forms file on the File menu of the applicable program to create a 
new Taxprep Forms file and automatically copy data from the Identification of the T1, T2 or T3 
client file to the Identification form in the new Taxprep Forms file. Once the file is created, it 
will be automatically opened in Taxprep Forms. 

Accessing Forms 
There are two different methods for accessing forms in Taxprep Forms: selecting forms from 
the Form Manager or using Xpress. 

Form Manager 
To access the Form Manager, press F4 or click the Form Manager icon on the toolbar. 

The Form Manager provides easy access to the various forms available in Taxprep. 

Simply select the form that you want then press Enter or double-click to open the form. 

To help you locate your forms quickly, Taxprep assigns a jump code for each form. Simply 
start typing the jump code and Taxprep will search for that code. 

If you don’t know the jump code of a form, you can use the Search field on the Toolbar (or 
press Ctrl+F). Simply enter your search text and the program will display all of the forms that 
contain that search text as part of the jump code, title or description.  

Form Type 
Forms are also identified by type (e.g. T4/RL-1).  

You can customize the forms displayed on the Form Manager according to the type of form 
you require. Click the filter icon in the Type column to filter on the appropriate type of form. 
You can select multiple form types. Use the Search field at the top of the filter dialog to find 
a specific form type. 

Once the filter is applied, the Form Manager will only display the selected form types.  
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To return to the complete list of forms, click the close box at the bottom left corner of the 
Form Manager to clear the filter.  

 
You can also create your own custom group of forms that includes any combination of slips, 
schedules, and forms. Refer to the Help for more information on creating a custom group of 
forms. 

Open Forms 
Once a form is open, a tab for the form will appear at the top of the form display. Click any 
form tab to view an open form. Click the Close (X) button or press ESC to close the form and 
remove the form tab. 

You can also access forms by drilling down from a form using the Expand command. 

You can use F6 to toggle back and forth between the current form and the last form viewed. 

Use F8 to toggle between federal and provincial equivalent forms. 

Press F4 to toggle between the Form Manager and the open forms. 

Note: The program will retain information about what forms were opened and where the 
cursor was positioned, so that the next time the file is opened (by any user), the same forms 
will be opened automatically.  

Xpress 
Taxprep Xpress allows you to view the data in the client file in a table format. You can select 
a filter to limit the data that you are viewing (e.g. only view the overridden data). 

The data in the Xpress table is fully interactive with the data in the forms. Any change made 
on the form will be immediately reflected in the Xpress table and vice versa. 

If the client file was rolled forward from a prior year Taxprep Forms file, the data entered in 
the prior year is displayed in Xpress. As a result, instead of jumping from form to form to 
enter data, with Xpress, you can simply scroll through the list of data entered in prior years 
and type in this year’s amounts. 

On the View menu, click Xpress (or click the Xpress icon on the toolbar) to display Xpress. 

You have two options for displaying Xpress: Dock and Float. 
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If you choose Dock, Xpress will be displayed in a pane at the bottom of the Taxprep window. 
If you choose Float, Xpress will be displayed in a separate window which you can reposition 
(e.g. onto a second monitor). 

Xpress can also be a useful tool for reviewing the return. See page 18 for more information. 

Expand (F9) 
When you are on a form, you can move to another related form by “Expanding.” 

Expanding allows you to move from one form to another without first going to the Forms 
Manager. You can expand from any cell with an arrow symbol beside it  to 
display that cell’s source form. 

Access a source form from an expandable cell as follows: 

• On the Forms menu, click Expand. 

• Right-click and then click Expand on the shortcut menu. 

• Press F9, or 

• double-click the cell.  

Cell Display 
Taxprep Forms uses flags to identify the properties of the cells. The colours indicate if the cell 
is calculated, calculated but overrideable, or input. The following are descriptions of the most 
common cell display: 

Cell Type Appearance Definition 

Input cell 
 

Black text on white 
background  

Data entry cell. 

Protected cell 
 

Black text on same 
colour background as 
the form 

No input or override is 
possible. 

Overrideable cell 
 

Black text on grey 
background 

Calculated cell where content 
can be overridden. 

Overridden cell 
 

Black text on pink 
background 

Calculated cell where content 
has been overridden. 

Cells with data entered last 
year but not this year. 

 

Black text on yellow 
background 

Cell in which data was entered 
last year but no value has been 
entered or rolled forward in 
the current year. 

Rolled forward cell 
 

Blue text on white 
background 

Cell that was rolled forward 
from the prior year 

Cell with diagnostic 
 

Red triangle in the upper 
right corner  

Diagnostic applies. 

Annotated cell 

 

Paper clip in the upper 
left corner 

Cell to which a note or 
schedule has been attached. 

Entering Data 
Entering data on the forms is made easy.  

 TIP 
As most client files 
use more or less 
the same forms and 
fields from one year 
to another, using 
Xpress is an 
excellent way of 
quickly accessing 
the fields that you 
are most likely to 
need to complete 
for the current year. 
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If an amount is a round figure, there is no need to enter the cents (“.00”). The program will do 
it for you. 

If an amount is a negative number, precede it with a “-”. 

Data can be entered into overrideable cells, simply by entering the data. The program will ask 
you to confirm the override before displaying the amount. 

Special Forms 

Multiple copy forms  
There are a number of tax forms for which you may require several copies. For example, on 
the data entry screens for T-slip recipients, you will require a separate copy for each 
recipient. 

For these forms, Taxprep allows you to create multiple copies of the forms. A Multiple Copy 
toolbar appears at the top of each multiple copy form to simplify navigation between copies.  

 
 

 Displays the first copy of the form. 

 The Previous button displays the previous copy of the form and the Next button 
displays the next copy of the form. 

 Displays the last copy of the form. 

 The Copies list provides access to all the copies that have been created.  

 The New button creates a new copy of the form and the Delete button deletes the 
copy displayed on the screen. 

 The Search button allows you to search for a specific copy of the form by entering 
any part of the description. 

Attachments 
You can create both attached notes and attached schedules. Once a note or schedule has 
been attached to a cell, a paper clip will be displayed in the left corner of the cell. 

 

Attached Notes 
You can attach a note to any type of cell by right-clicking then selecting Attach Note or 
pressing Alt+F10. 
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If you want the note that you create to be rolled forward to next year’s return (e.g. because 
the note may also be applicable next year), select the following option:  

    
When you hover your pointer over a cell that has an attached note, the note will appear. 

Attached notes are summarized on the form Attached Notes - Summary (Jump Code: ATTN) 
which can be printed along with the return. The notes can be sorted according to the order 
the forms appear in the Form Manager. The name of the user that last edited the note, as well 
as the date the note was last modified, will be displayed on the Attached Notes – Summary. 

You can also navigate to a cell that has a note attached by double-clicking the name of the 
cell associated to the note from the Attached Notes – Summary. 

Attached Schedules 
The Attached Schedule with Total (Jump Code: ATTS) is a multiple copy form. Each time you 
attach a schedule to a cell, a new copy of the attached schedule is added to the form and 
linked to this cell. You can also add copies that are not linked to any cell. 

You can navigate to a cell that has the schedule attached by double-clicking the name of the 
cell associated to the note from the Attached Schedules.  

 

 
 

 
 
 
 

To attach a schedule: 

1. Select the numeric cell to which you would like to attach a schedule. 

2. On the Edit menu, select Attach Schedule. 

For more information on the Attached Notes and Schedules, refer to the Help. 

Multi-Line Tables 
Some forms contain multi-line tables. For example, Form T5013 Schedule 6 and Form T2057 
contain these tables. 

 TIP 
Jump to ATTS on the 
Form Manager to 
access all of the 
attached schedules. 
Use the Multiple 
Copies toolbar to 
find a specific 
attachment. 
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A new line (or set of lines) is automatically added as soon as data is entered. 

You can also use the Add button to create a new line or lines. Use the Delete button to 
remove a line.  

Client Letter  
Previewing a Letter 
Letter templates are linked to letters on the Form Manager. When you print or display a letter 
from the Form Manager, the template content is merged with the data in the forms or returns. 
The resulting document is a letter that contains information specific to each client’s 
situation. 

You can view the letter by entering the jump code for that letter preview similar to accessing 
any other form. 

 
 

Changing the Contents of the Letter 
You can change the contents of the client letter for a specific client in two ways: 

• Modify the data in the Client Letter Worksheet; or 

• Edit the Letter Preview. 

Modify the Client Letter Worksheet 
The Client Letter Worksheet (Jump Code: LW) is used to select and modify the information that 
appears in the client letters. Much of the information in the Client Letter Worksheet is 
determined based on the options you have selected in the Preparer Profile and/or the data 
entered in that specific file. 

The Client Letter Worksheet will show you which slips or returns are applicable to the file and 
their filing method. These are the slips that will be referred to in the Client Letter. You can 
determine whether or not the letter should refer to the filing deadline for these submissions. 

You can also enter the names of any specific forms that the taxpayer is required to submit or 
retain by jurisdiction as well as optional opening and closing paragraphs specific to that data 
file. 

Any data that you enter in the Client Letter Worksheet is saved in the client file. 

Editing the Letter Preview 
You can edit the letter preview to temporarily change the letter generated from your 
template. You can add, delete or modify the text in the letter as well as pasting in text from 
another source (e.g. a Word document). However, the edit will only stay in effect while you 
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are in the letter preview. The next time that you access the letter preview, your edits will be 
lost, as the preview will be regenerated from your template to ensure that it reflects the 
latest data in the client file.   

You can, however, save your edited version of the letter preview to an .rtf file which is 
compatible with word-processing programs, using the command Save Letter As on the File 
menu. If you have edited the preview, Taxprep will ask you if you want to save the edited 
preview when you leave the form. When the letter preview is saved, the program will give you 
the option of automatically opening the .rtf file in your word processing program.  

You can also print the edited letter preview using the Print Form command similar to any 
other form. 

Changing all Client Letters 
If you want to make a change for all of your client letters (e.g. change the wording of a 
specific paragraph, or add the firm logo to the letter), you can edit the appropriate letter 
templates.  

For information on editing the letter templates, refer to the Help. 

Labels 
You can print labels for your clients and for slip recipients. The label templates can be 
modified in the Letters and Labels view.  

Client Mailing Labels 
To print mailing labels for your clients, you should enable the appropriate option in the 
Preparer Profile.  

 
Labels for your clients can be printed along with your forms and/or returns by setting the 
Form Labels - Preview and Print (Jump Code: LPP) to print If Applicable in any print format 
(e.g. your customized client copy). You can specify a printer or printer tray for the label to 
allow you to preload the label pages in your printer. 

Slip Recipient Mailing Labels 
To print labels for your slip recipients, use the command Print Labels.  

To print labels for slip recipient labels for multiple client files at the same time, select the 
client files in the Client Manager and then select File/Print Labels. 

The type of label that you will be printing to can be selected in the “Labels” section of the 
Options and Settings dialog box accessible from the Tools menu. 

Importing and Exporting Data 
Taxprep Forms allows you to import and export the following types of files:  

• .csv files (separator: semicolon). This file format contains items from a spreadsheet or a 
database with cells separated by semicolons and can be created with any type of text 
editor; 

• .xls files (worksheet). This type of file is created with Microsoft Excel©. 
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Refer to the Help for more information on importing and exporting data. 

Importing and Exporting Slips 
Taxprep Forms allows you to import and export the following type of files that contain slip 
data:  

• .csv files (separator: semicolon). This file format contains items from a spreadsheet or a 
database with cells separated by semicolons and can be created with any type of text 
editor; 

• Personal Taxprep Data: When you print or transmit certain T-slips, a database will be 
created automatically that will allow you to import that T-slip data when you open the 
related tax return in Personal Taxprep.  

Refer to the Help for more information on importing and exporting slips. 

Saving Client Files 

You must click the Save icon  to save the data. If you attempt to close the client file 
while there is unsaved data, Taxprep Forms will prompt you to save the file prior to closing it.  

Taxprep Forms will also save a periodic backup copy of your data files if they contain any 
unsaved data. You can modify the interval at which the backup files are saved in Options and 
Settings. 

The file extension will vary depending on the year end of the client file (i.e., .T25 for a 2025 
year end and .T26 for a 2026 year end).  

 

 

 

When you save a file, by default Taxprep 
will display the Properties dialog box. 
This includes a section for notes that can 
be used to record information about the 
return.  

These notes can be edited and viewed in 
the Client Manager. When rolling forward 
your files, you also have the option to roll 
forward these notes. 
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Attaching External Files 

You can attach any external file to your client file by clicking the  icon on the toolbar or 
the Attached Files command on the File menu.  

You have the option of either saving a link to the selected file or embedding a copy of the 
selected file within the Taxprep data file.  

This dialog box is also accessible by pressing Ctrl+F11. While almost any type of file can be 
attached, you cannot attach file types that are executable and could therefore present a 
security risk (e.g. .exe, .bat, .chm, .js).  

You can also automatically attach a PDF file generated using any of the print commands in 
Taxprep Forms.  

For more information on attaching external files, refer to the Help. 

Reviewing Client Files 
Once you have entered all of the information into the client file, you should review it to 
ensure accuracy. There are several ways of reviewing the client file: 

Xpress 
Taxprep Xpress can also be used to review and verify data. It offers many filters and allows 
you to review overridden and marked cells in the client file by selecting the appropriate 
Xpress filter. 

Track Changes 
During the review process, you may wish to monitor any changes made to the forms to ensure 
that only the identified corrections are made and that no data is changed inadvertently. 

Activate the command Track Changes on the Edit menu and any changes made to the forms 
after that point will be tracked and can be viewed in Xpress using the filter “Data Modified 
after activating Track Changes.” 

Monitor 
The monitor is a tracking tool that lets you display key tax information at the bottom of the 
client file window.  

On the View menu, click Monitor to display or hide the monitor. 

To add a cell to the Monitor, simply click the cell that you want to view and drag it onto the 
Monitor.  

When you customize the Monitor’s contents, these settings are saved for your workstation 
and will apply to all client files. 

 
Diagnostics 
You can display the list of diagnostics so that you can consult them as you work on the client 
file. 

To view the list of diagnostics, click Diagnostics on the View menu or click  on the 
toolbar. 

You have two options for displaying the diagnostics: Dock and Float. 

If you choose Dock, the list of diagnostics will be displayed in a pane at the bottom of the 
Taxprep window.  
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If you choose Float, the diagnostics will be displayed in a separate window which you can 
reposition (e.g. onto a second monitor). 

You can also use the hotkey Alt+F5 to display the docked list of diagnostics and the hotkey 
Alt+F6 to display the floating list of diagnostics. Alternatively, you can access the 
Form Manager and enter the Jump Code DIAG to display the diagnostics. 

Once the diagnostics are displayed, you can switch between display modes using the 
icon on the Diagnostics toolbar. 

To display diagnostics directly on a form, point to a cell with a diagnostic’s indicator and the 
diagnostic message will be displayed. This information is available regardless of whether or 
not the diagnostics pane is visible. 

Diagnostics can be printed directly from the Diagnostics pane (either floating or docked) 
using the command File/Print Diagnostics or they can be included in a print format so that 
they are printed along with forms.  

Customized Diagnostics 
You can also create your own diagnostics in Taxprep in the view Filters and Diagnostics. 
These diagnostics can be used to check for adherence with firm procedures (e.g. partner 
name entered) or as a reminder for specific data entry requirements or tax issues.  

Any diagnostics that you create that are applicable to the current client file will appear in the 
tab My Diagnostics on the Diagnostics pane.  

Refer to the Help for more information on how to create custom diagnostics. 

Review Mode 
When a client file is being reviewed, the review mode allows you to add review marks to the 
appropriate cells in the forms simply by clicking them. 

Review marks can be used to identify whether the data is correct as well as incomplete.  

The following review marks are available:  

Symbo
l 

Name of the 
review mark Recommended when... 

 First review The reviewer wants to indicate that the content of a cell has 
been reviewed once. 

 
Second 
review 

The reviewer wants to indicate that the content of a cell has 
been reviewed a second time. 

 Error The reviewer wants to let a preparer know that the content of 
a cell contains an error. 

 Uncertainty 
The preparer wants to indicate that he or she is uncertain of 
the content of a cell. This mark can also be used to represent 
an estimate. 

 
Other  

The preparer wants to indicate that the content of a cell must 
be reviewed for a reason other than the one previously 
mentioned.  

Reviewing Diagnostics 
You can mark diagnostics as “Reviewed” or “Ignored” by right-clicking the diagnostic in the 
Diagnostics pane and selecting the desired annotation.  

By default, all diagnostics will appear under the Take Action tab in Diagnostics pane. 
However, once a diagnostic is marked as “Reviewed” or “Ignored,” it will no longer appear 

 TIP 
The review mode 
can be used from 
the Xpress tool. 

mk:@MSITStore:C:%5CProgram%20Files%5CCCH%5CT1%20Taxprep%202006%5CHelp%5CTP1%5CTxpTechE.chm::/ReviewMarkAdd.htm
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under the Take Action tab but will instead be shown in the Reviewed or Ignored tab, as 
applicable. 

This allows you to mark any diagnostics that cannot be cleared (e.g. a filing reminder), so that 
upon subsequent review, you will know which diagnostics you have already reviewed. 

Electronic Signatures 
If you are using CCH iFirm Portal, you can take advantage of the built-in tags for e-signatures 
that have been integrated into various forms. These tags will indicate where the digital 
signature must be affixed, allowing you to streamline the publishing of forms that require 
your customer’s digital signature.  

For more information, refer to the Help Centre for Taxprep Forms and/or the Help Centre for 
CCH iFirm Portal. 

Printing 
Printing Forms 

Individual Forms 
In the Forms view, you can print individual forms for any of the active client files.  

On the File menu, click Print Form to print the current form that is on screen.  

Note: When you use the Print Form command on a multiple copy form (e.g. Form T5013CCA), 
only the current copy will be printed. To print all copies of a multiple copy form, select the 
entry on the Form Manager and then click Print Selected Form(s).  

Multiple Forms 
To print more than one form at the same time (but not necessarily the whole client file): 

1. Select the forms on the Form Manager.  

2. On the File menu click Print Selected Forms. 

3. Click OK to start printing. 

Note: When viewing a form, the print command is called Print Form. When on the Forms 
Manager, the print command is called Print Selected Forms. 

Form Printing Options 
You can select a number of options when printing individual forms: 

• Print to PDF file 

• Print a blank copy of the selected form(s).  

• Print the form as displayed on the screen. 

• Override the date to be printed on the form(s). 

• Page range to be printed (single form only). 

• Print a watermark on the form(s). 

• Use zoom printing to print more than one page per sheet of paper. 

• Select the language in which the form will be printed. 



Taxprep Forms Quick Start Guide 

21 

You can also click the Options button to modify any of the print settings previously 
configured under Options and Setting or to select PDF file options. 

Printing Client Files 
You can print the client files by clicking Print Based on Print Formats on the File menu. 

Viewing Diagnostics 
When you use the Print Based on Print Formats command and there is at least one diagnostic 
that needs to be corrected, the diagnostics will be displayed automatically.  

Click Continue if you want to proceed with printing the client file.  
Selecting Client Files 

 
The client files will be displayed, and you can indicate with which jurisdiction(s) the client file 
must be filed, based on the applicable forms. You will be able to select the client file you 
want to print. 

Note: The selection of what will be printed for each copy of the client file is saved in a 
template file called a Print Format. For more information on customizing print formats, refer 
to the Help. 

All of the available print formats will be listed. You can change which print formats are 
selected by clicking the adjacent check box.  

All selected print formats will be produced for each client file (e.g. a client copy, a 
government copy and an office copy will be printed).  

If you want to generate a PDF file instead of printing a hard copy, click the PDF box.  

You can select a different watermark for each copy. 

Click Options to change any of your configured print options prior to printing.  
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Printing Multiple Client Files 
If you want to print several client files, select the client files on the Client Manager then click 
Print Based on Print Formats as you would for a single file. 

Printing Slips 
There are different ways to print slips to issue to recipients.  

Print the Client File 

If you are using the Print Based on Print Formats command, the slips selected for filing (i.e. 
the slips for which the check box has been selected on the line Select this box if you want to 
file this slip/RL-slip) on the different slips will be printed depending on the selected printing 
method (for example, if you want to print T4 slips on preprinted forms, select the Govt-Pre 
print format). 

Print Selected Forms 
The Print Selected Forms command also allows for the printing of slips. You can print copies 
of the recipient’s slips while they are displayed or you can print all copies of the slips 
selected for all recipients from the Form Manager.  

Print Slips 
Finally, you can use the specific Print Slips command. The main difference between this print 
command and the Print Based on Print Formats or Print Form commands is that you can print 
a single type of slip having a specific type of data. For example, with the Print Slips command, 
you can print the T4 slips with the "Original" type only. This print method allows you to print 
slips for the active client file or for several client files, by selecting them from the Client 
Manager.  

You must indicate that you will be proceeding with the electronic transmission by answering 
“Yes” to the applicable question in the Preparer Profile. 

Printing Slips to PDF 
When you select the PDF option within any of the above-mentioned commands, you have the 
option to generate a separate PDF file for each slip and automatically assign a password to 
that file, if applicable. This can be configured on the PDF Files tab of the Print dialog box or in 
advance in the Print/PDF Files section of Options and Settings. 

Electronic Filing 
Taxprep Forms allows you to generate files that can be used to electronically file slip 
information to government authorities via the Internet. You can also electronically file T5013 
Partnership Information returns and T5013 slips. 

Mandatory Electronic Filing 
Electronic filing of information returns (e.g. T-slips) is mandatory at the federal and Québec 
levels where there are five or more slips.  

Each slip is an information return, and the penalty the CRA assesses for paper-filing is based 
on the number of information returns filed in an incorrect format. The penalty is calculated 
per type of information return. 

Note that while electronic filing of the T5013 Partnership return is currently optional, the 
T5013 slips and summary are subject to mandatory electronic filing.  

The Québec TP-600 return, Partnership Information Return, cannot be electronically 
transmitted. It must be paper-filed. 
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Configure the Program 

Enter ID Information 
The tax authorities require detailed information concerning the identification of the 
transmitter. The required information differs depending on whether the information is being 
transmitted to the CRA or RQ.  

For federal transmissions, a transmitter account number (i.e. business number) or a RepID 
must be included in the transmission file. The transmitter account number is required when 
filing using the Internet File Transfer service or if you are a business owner and want to 
upload the file through the My Business Account service. Your RepID must be included in the 
transmission file you are going to be uploading on behalf of your client through My Business 
account via the Represent a Client portal.  

A Web access code (WAC) is required to log into the Internet File Transfer service. This WAC 
must be associated with the transmitter’s business number. Entering the WAC in the 
Electronic Services > Identification settings is optional. If it is entered, then the program will 
display the WAC in the window that appears to the left of the CRA’s Internet File Transfer 
service login screen to assist you in accessing the service.  

To enter this information in the program, proceed as follows: 

1. In the Tools menu, click Options and Settings. 

2. Under Electronic Services, click Identification. 

3. In the Identification section, click the  button, and enter the information concerning 
the transmitter and the resource persons.  

4. If you are transmitting slips or returns to the CRA, click Federal, and enter the required 
information.  

5. If you are transmitting slips to Revenu Québec, click Québec, and enter the required 
information.  

6. Click OK to save the changes.  

Note: The mandatory information is identified by a red triangle in the upper right corner of 
the fields.  

Enter Slip Numbers 
If you are electronically filing Québec slips, you must enter in the program the range of 
numbers assigned to you by Revenu Québec. When the file to transmit is generated, the 
program will assign a unique number to each slip filed.  

Note: If there are multiple users responsible for generating slips and you are not using the 
Network version, you will need to ensure that there is no duplication of slip numbers. You 
may therefore want to distribute the assigned number range among the staff responsible for 
generating the slips. 

 

To enter the range of slip numbers, proceed as follows: 

1. On the Tools menu, click Options and Settings. 

2. Under Electronic Services, click Slip Numbers. 

3. In the First box, enter the first number in the range.  

4. In the Last box, enter the last number in the range.  
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5. In the Next Number box, the program automatically indicates the next number that will 
be used according to the numbers already attributed to slips. If you want, you can 
manually enter the number you want the program to attribute to the next slip.  

6. Click OK to save changes. 

Note: RQ requires that these numbers appear on the printed slips. Therefore, you must 
generate the slips before printing them, in order for the program to assign the numbers.  

Define Transmission Options by Default 
The program allows you to define the options to be used by default for each slip 
transmission. To modify these options, proceed as follows: 

1. In the Tools menu, click Options and Settings. 

2. Under Electronic Services, click General. 

3. If you want to save transmission files in folders other than the ones suggested by default, 
click the  button, and select the desired folder.  

4. The appropriate portal login page for the CRA or RQ will automatically display during 
transmission. If you want to generate the file for Internet transfer but upload the file at a 
later date, clear this option.  

5. Click OK to save changes. 

Prepare Client Files 

Preparing Client Files 
Prepare the client files in the normal fashion. Ensure that the data for the recipients’ slips or 
partnership returns was properly entered. 

Allow EFILE 
EFILE must be activated in order for the slips or return of the selected client file to be 
transmitted to the tax authorities. To activate EFILE for all the prepared client files, you must 
specify it in the default preparer’s profile as follows: 

1. Create or modify a preparer’s profile. 

2. In the “EFILE information” section, select the Allow electronic filing check box. 

3. Click Save to save the changes. 

Verify if Eligible for EFILE  
When EFILE has been allowed for a client file, the program will determine if each slip is then 
eligible for EFILE as well as the T5013, if applicable. 

The EFILE status of a slip is “Eligible” when EFILE is allowed and a client file: 

• includes at least one of the slip types in question; and 

• meets eligibility requirements. 

The EFILE status for a return is “Eligible” when EFILE is allowed and there is no missing or 
inconsistent data as indicated in the EFILE diagnostics.  

To verify that a client file meets the eligibility requirements for EFILE, proceed as follows: 

1. Display the Diagnostics pane. 

2. Click the EFILE tab to verify any EFILE diagnostics. 
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Note: Diagnostics are only displayed if EFILE has been allowed.  

If the client file meets eligibility requirements for EFILE and no EFILE diagnostic is issued, the 
EFILE status for slips and/or return will then be “Eligible” and this type of diagnostic will be 
displayed for each applicable slip as well as for the return (if applicable): 

 

Errors detected  
Non-eligibility transmission errors are indicated in the diagnostics pane under the EFILE tab. 
They must be corrected in order for the slips or return to be eligible for EFILE purposes. 

Transmitting 
The program allows you to transmit information returns (e.g. T-slips) for one or several client 
files at a time. However, all of the T-slips being transmitted together must be the same type 
(e.g., T4 slips). Before completing the transmission, you can display the list of all slips that 
will be transmitted. In case of errors or problems preventing the transmission of slips, the 
program will inform you of the problem to correct.  

Note that as of January 2025, it is no longer possible to combine both the T5013 return and 
T5013 slips in a single transmission.  

Transmit for a single client file  
To transmit slips or returns for a single client file, proceed as follows: 

1. Open the client file in the Forms view, or select the client files in the Client Manager.  

2. In the Transmission menu, click Transmit. 

3. Select the slip/return and the type of data to transmit.  

4. Click OK to generate the file to transmit. 

Transmit for several client files 
If you select several client files, the slips/returns will then be transmitted together in the 
same file. To transmit slips/returns for several client files, proceed as follows: 

1. Select the client files in the Client Manager. 

2. In the Transmission menu, click Transmit. 

3. Verify the client files you want to transmit. You can remove a client file from this 
operation by clearing the box next to the client file.  

4. Select the slip/return and the type of data to transmit.  

5. Click OK to generate the file to transmit. 

Display slips/returns to transmit 
From the Transmit dialog box, it is possible to display, for every selected client file, the list of 
slips/returns that will be included in the transmission. To display this list, click the scroll 
down list under the Details column.  

• It is possible to sort the list of slips/returns by clicking the header of the desired column.  

• You can enter characters to search for an element of the list.  



Taxprep Forms Quick Start Guide 

26 

• If a slip has already been generated, the Date – Type of data column appears in the list 
and indicates the date on which the creation took place.  

• To display all slips contained in the client file, rather than only the ones to transmit, clear 
the Only show slips to be transmitted option. 

Note: If a client file cannot be selected for transmission because of an error, it is not possible 
to display a list of these slips. 

Consult Error Messages 
If an error prevents selection of a client file, a red triangle will be displayed under the Details 
column of the Transmit dialog box. To display the error details, place the cursor over this 
indicator. An error could occur, for example, in the following cases: 

 a client file is not eligible to transmit the selected slip/return because EFILE diagnostics 
exist; or 

 a client file is eligible to transmit the selected slip/return but does not contain any 
slip/return that corresponds to the selected type of data (for example, you have selected 
“Amended”, but the client file only contains “Original” slips).  

In case of an error, it is not possible to transmit the slips/return in the client file. Please 
correct the problem indicated by the program. 

Creation of the File to Transmit 
When you click OK in the Transmit dialog box, the program creates the file to transmit in one 
of the folders specified in the Options and Settings. By default, the folder is the following:  

• \...\My Documents\Wolters Kluwer\Taxprep Forms 20**\Generated slips 

For the federal slips, the name of the saved folder is AABBBBBBCCCvariable.xml, where AA 
stands for the taxation year, BBBBBB that stands for the transmitter number and CCC stands 
for the clock for each file prepared. The variable that follows the name of the saved file can 
be either the first 14 characters of the name of the tax filer (where a single client file is 
transmitted), or the number of transmitted files (where several client files are transmitted).  

When you create Québec RL slips, the name of the saved transmission file is 
DDEEEEEEFFF.XML, where DD stands for the taxation year, EEEEEE, which stands for the 
preparer’s number, and FFF stands for the clock for each produced file.  

Note: The generated file name is a maximum of 30 characters. 

The file saved in this folder will remain available thereafter. 

Contents of Transmission File 
The transmission file will contain the selected slips as well as the associated summary. For a 
T5013 return, the transmission file will include information from the T5013FIN return as well 
as information from the schedules. Note that if you are required to file a T5013 Schedule that 
is not yet available in Taxprep Forms, you must attach a copy of the schedule (PDF) with your 
return (either by paper-filing the return or by uploading the additional forms using the CRA’s 
Submit Documents service. 

Internet Transmission Help Window 
When you transmit slips via the Internet, a window will display to the left of the CRA or RQ 
portal by default. When transmitting to the CRA, the Internet File Transfer service login page 
will appear if you have entered a transmitter account number in the Electronic Services 
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Identification dialog box. Alternatively, if you have entered a RepID in the Electronic Services 
Identification dialog box, the sign-in page for your CRA account will be displayed. 

The window will display various information that will assist you in uploading your file. Once 
your file has been successfully uploaded, you can enter the confirmation number provided. 
This number will then be transferred to the relevant client file. 

CRA Error Checking 
When a file is uploaded to the CRA, the CRA will perform an electronic filing validation. For 
smaller files (2MB or less), this is done online at the time of submission. If no errors are 
found, a confirmation of receipt page will appear. If errors are found, then an error report will 
appear. The error report can contain both warnings and errors. It is recommended that, if 
errors have been identified, you cancel the upload process, correct the errors and resubmit 
the entire file.  

For larger files (greater than 2MB), the validations will be done offline (i.e. after the file has 
been submitted). If errors are found, a CRA agent may contact the filer. An error may result in 
an information return being rejected, in which case the error will be identified in the My 
Business Account service and the return would need to be resubmitted.  

Electronic Filing Follow-up 

EFILE Status 
Once the creation of transmission files is completed, the program will automatically assign 
the “Generated - <Type of data>” to the EFILE status of the slip or return for each client file 
transmitted.  

For example, if you have transmitted “Amended” RL-16 slips, the EFILE status will be 
“Generated – Amended.” It is possible to consult this status from several places in the 
program, such as the Properties dialog box for the file and in the Client Manager. 

Note: A file with a “Generated” status can be transmitted again, if necessary, since the 
program continues to validate its eligibility to EFILE even after transmission.  

EFILE Info Form 
The Form EFILE Information (Jump Code: EFILE INFO) will display the date that you transferred 
your transmission file for the various transmissions associated with that client file. It will also 
show the confirmation number that you entered in the Transmit XML File window. 

FILE History 
The EFILE transmission history displays the list of client files for the slips that were 
transmitted from the Client Manager.  

You can use this list to generate a report or retransmit slips, where problems have occurred.  

Note: This history is not produced if the transmission is done from an active client file.  

For more information regarding electronic filing, refer to the Help. 

Amending Slips 
If you amend slips, then you should file the amended slips using the same filing method you 
used with the original slips (i.e. if the original slips were paper-filed, then you should paper-
file any amended slips). 
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Help 
The following Help resources are available in the program: 

Tax and Form Help 
Context-sensitive tax help is easily accessible from each cell by pressing F1 or by clicking 
Taxprep Forms Help on the Help menu. 

The Help Centre is online and requires Internet access. The Help Centre includes information 
about using the program, completing the tax forms, electronic services, FAQ’s, 
Troubleshooting and Release Notes. It also includes links to many CRA and Revenu Québec 
guides. 

Knowledge Base  
Our Knowledge Base contains an array of articles answering technical and tax questions most 
frequently asked to our Support Centre agents. When you enter a few key words in the Search 
field, articles will be displayed in order of relevance, providing you with valuable information 
that will accurately answer your questions. You can use the filters on the left side of the 
screen to filter the results by product.  

You can access the Knowledge Base from the Help Centre or directly from the 
Professional Centre. 

Tax Research Links 
You can access your Tax Research products directly from the Help menu. 

Technical Help 
To get help on the operation of the program (as opposed to the tax forms), access the Help 
Centre by clicking Taxprep Forms Help on the Help menu and then use the Search function to 
find relevant help topics. You can also click the Help button in the various dialog boxes.  

Virtual Agent 
You can also obtain assistance using the advanced virtual agent.  

Click the Virtual Agent button located in the top right corner of the program. 
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The virtual agent provides: 

• Direct descriptive answers to your queries based on our knowledge base articles, 
allowing you to benefit from an efficient virtual conversation 24 hours a day, 7 days a 
week. 

• The ability to chat with a live agent during business hours, so you can discuss your 
question with a person in real time. 

• The option to submit a support case.  

Note that you must register for the Support Platform to access your requests and be able to 
follow up on them. 

Training 
You can find information about current training opportunities by clicking Get Taxprep 
Training on the Help menu. 

 

 

https://support.cch.com/oss/canada/kb/solution/000268188?language=en
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